home | list info | list archive | date index | thread index

Re: [OCLUG-Tech] need help solving an issue with my network

Have you found the problem yet?

My Linksys router had a problem where if it was running for a few days without a power cycle the DHCP service would crash so any new machine or phone trying to lease an IP wouldn't be able to but those already issued IP's worked fine. Power cycle the router and it would work, annoying as hell but finally they issued new firmware that fixed this.

Andre Gregoire
Senior Enforcement Officer
Electronic Commerce Enforcement
Canadian Radio-television and Telecommunications Commission (CRTC)
andre [ dot ] gregoire [ at ] crtc [ dot ] gc [ dot ] ca
Telephone 819-953-6972
Government of Canada

-----Original Message-----
From: linux-bounces [ at ] lists [ dot ] oclug [ dot ] on [ dot ] ca [mailto:linux-bounces [ at ] lists [ dot ] oclug [ dot ] on [ dot ] ca] On Behalf Of Brenda J. Butler
Sent: January-01-12 12:09 PM
To: linux
Subject: Re: [OCLUG-Tech] need help solving an issue with my network

Do the machines with DNS problems get their IP addresses via
DHCP?  Do they get their nameserver info from DHCP as well?

If so, is DHCP still working?  DHCP-assigned addesses have
to be renewed via leases.

Maybe the kids machines/phones DHCP leases expired before
the other leases ...

Have you done an upgrade lately?  Changes to the firewall?

You can use the dig command to direct DNS queries to a particular
DNS server:

    dig @server.to.query domain.to.ask.about
    dig @server.to.query domain.to.ask.about NS

Hope this helps - do send more questions if you have them.


On Sun, Jan 01, 2012 at 11:55:53AM -0500, ed stuckems wrote:
> Folks:
> This may be slightly off-topic, so I hope you'll consider this request
> for help appropriate for this list.
> My home network is suddenly misbehaving and after poking around a bit
> I'm at a loss to explain why things aren't working and I can't seem to
> fix the problem.  Any help/advice would be greatly appreciated.
> Here's the problem ... My kids' computers recently stopped serving web
> pages.  After poking around a bit, it appears that dns requests from
> their machines aren't being resolved.  Poking around more, I've
> discovered that the game consoles and the android based phone aren't
> working either and I suspect it's for the same reasons.  The phone
> worked on the wifi network as recently as last week.  However, there
> are machines on the network that are working!   My linux box, mac book
> pro (running Mac OSX), iPad, and Windows Vista computers are all
> working.
> All the machines are able to access internal machines/servers/services
> via ip address (I'm not using dns for internal servers) and everything
> internal can be pinged and is able to ping (most) everything else.  On
> those machines that aren't working, nslookup is not able to resolve
> host names and nslookup returns stating that the dns server(s) timed
> out.
> There are 2 dns servers provided to clients on the network: the
> caching server on the router, and the dns server provided by my
> service provider.  nslookup reports time outs for both servers.
> I'm at a loss to explain what's happening and any advice or guidance
> for correcting the issue would be greatly appreciated.
> regards
> eds.
> _______________________________________________
> Linux mailing list
> Linux [ at ] lists [ dot ] oclug [ dot ] on [ dot ] ca
> http://oclug.on.ca/mailman/listinfo/linux
---end quoted text---
Linux mailing list
Linux [ at ] lists [ dot ] oclug [ dot ] on [ dot ] ca