home | list info | list archive | date index | thread index

Re: [OCLUG-Tech] can't copy some files

The microSD card file system probably doesn't support long filenames or
non-alphanumeric filenames. Executing

will show you the file system type, probably "vfat", and the options it
was mounted with. Read

    man mount
to understand the options.

Depending on what other systems will see the microSD card (and what they
support), you MAY consider formatting the microSD with a different

-----Original Message-----
From: Bruce <lists [ at ] faintfuzzies [ dot ] ca>
To: linux [ at ] lists [ dot ] oclug [ dot ] on [ dot ] ca
Subject: [OCLUG-Tech] can't copy some files
Date: Tue, 20 Sep 2016 20:27:15 -0400

My trying to put my music collection on microSD card.  I've tried this 
numbers times and I keep getting the same errors with just certain files.  
When I go to copy I get no such file or directory.  Now if I try to copy them 
to say the tmp directory, they copy just fine.  I ran e2fsck and the results 
where I had a good hard drive and microSD card.

Sample of what I'm trying to copy:

cp /tmp/Herbert\ Von\ Karajan\ -\ 01\ -\ BEETHOVEN\ \:\ Symphony\ No.6\ in\ 
F\ major\,\ Op.68\ \"Pastoral\"\ -\ 1.\ Allegro\ ma\ non\ troppo.flac 

I thought maybe the title was too long so I also renamed some of the 
offending file, but got the some result.  I tried copying them to a different 
hard drive and that worked fine.

Googling produced no help, so here I am.  Any ideas?

Linux mailing list
Linux [ at ] lists [ dot ] oclug [ dot ] on [ dot ] ca