home | list info | list archive | date index | thread index

Re: [OCLUG-Tech] Still no DSL connection.

Hello Fred,
Actually, there should not be any problem in setting up ADSL connection (I did this in one evening).
1. Build and install an rp-pppoe package.
2. Disable all firewalling rules (you need this for starting up. Noone is going to hack you when you set up your connection).
3. Check that your /etc/modules.conf contains the following lines:
alias char-major-108 ppp_generic
alias /dev/ppp ppp_generic
alias tty-ldisc-3 ppp_async
alias tty-ldisc-13 n_hdlc
alias tty-ldisc-14 ppp_synctty
alias ppp-compress-21 bsd_comp
alias ppp-compress-24 ppp_deflate
alias ppp-compress-26 ppp_deflate
4. Run adsl-setup script and enter parameters of your ISP.
5. Edit files /etc/ppp/pppoe.conf. You may need to set up PPPD_EXTRA=debug and even "debug kdebug 7".
6. You may need to cheate a file adsl in /etc/init.d directory like this:
#!/bin/sh # # This is an ADSL start script # # chkconfig: - 94 08 # # description: This shell script starts ADSL connection # # Source function library. . /etc/rc.d/init.d/functions [ -f /sbin/adsl-start ] || exit 0 [ -f /sbin/adsl-stop ] || exit 0 # See how we were called. DAEMON="/sbin/adsl-start" prog="adsl" start () { # start daemon [ -f /var/lock/subsys/adsl ] && exit 0 echo -n $"Starting $prog: " daemon $DAEMON RETVAL=$? echo [ $RETVAL = 0 ] && touch /var/lock/subsys/adsl return $RETVAL } stop () { # stop daemon echo -n $"Stopping $prog: "
       killproc /usr/local/sbin/trafd
-USR2 sleep 1 killproc /usr/local/sbin/trafd -INT /sbin/adsl-stop && rm -f /var/lock/subsys/adsl RETVAL=$? echo }
Use it for reference only!
Run adsl-start and check your connection. Watch /var/log/messages.
7. After you could ping or connect a site in the Internet, try to set up firewalling.
Hope this helps.

Fred Williams wrote:

	OK if there's anybody who knows how to set up a DSL connection on
Linux, please answer.  I have been trying since April 26th and many
problems have been fixed.  My ISP blames the phone company, the phone
company says the lines are fixed and that the last outstanding order was
cancelled today.  Fine.  I found a loose connection myself today and now
the ADSL modem actually gets a reliable link to the host, ... flashing
green DSL LINK light turns solidly lit!  Both LAN lights on!
	I still get no connection when I try to activate.

1.  Could the firewall be blocking the service?...SE Linux is active.
2.  Do I have to set netmasks and so on, because my system fails to
obtain IP information for eth0.  That is probably the main problem. I'm
guessing, but if the eth0 isn't working how can anything connected to it
connect?... Right??!!