home | list info | list archive | date index | thread index

[OCLUG-Tech] still struggling with booting centos 6.5 with UEFI ...

  • Subject: [OCLUG-Tech] still struggling with booting centos 6.5 with UEFI ...
  • From: "Robert P. J. Day" <rpjday [ at ] crashcourse [ dot ] ca>
  • Date: Sat, 18 Jan 2014 09:03:42 -0500 (EST)
  following up on the earlier discussion, i thought i had things all
worked out but ... not quite. thus far, here's what i've managed to

  on the asus ultrabook i'm working on, there are three USB ports, one
of them being a superspeed (SS) port, so here's what i've done. centos
6.5 does not install using EFI natively, but the installation DVD
comes with an images/ directory containing a bootable "efidisk.img"
file, so i dd'ed that file to an empty USB drive.

  i then dd'ed the installation DVD image to a *second* USB drive to
act as the installation media and, finally, i inserted a *third*
superspeed USB drive in SS port -- the installation target. so the
contents of the three USB ports:

  1) tiny, bootable efidisk.img
  2) 4G install DVD image
  3) 16G, superspeed target USB drive

the idea is to boot from 1), select 2) as installation source, and
select 3) as target drive. and it all seems to work -- takes a half
hour, after which i have what looks like a valid UEFI USB drive with
the proper structure.

  i then shut down, remove the first two USB drives, leave the target
drive in, power up, stop in the BIOS and, sure enough, there are two
boot options:

  * Windows Boot Manager ...
  * UEFI: Sony Storage Media 1.00

however, no matter what i do, i can't get the BIOS to boot from that
second choice. if i choose it explicitly and hit ENTER, almost
immediately, i'm dumped back to the same menu.

  i've tried various combinations of enabling and disabling Secure
Boot, with no success. it seems the BIOS is aware of that USB drive,
but simply refuses to boot from it.

  this is the "Aptio Setup Utility", so if anyone has any suggestions,
i'm open.


Robert P. J. Day                                 Ottawa, Ontario, CANADA

Twitter:                                       http://twitter.com/rpjday
LinkedIn:                               http://ca.linkedin.com/in/rpjday