home | list info | list archive | date index | thread index

Re: [OCLUG-Tech] Rescuing user from his own stupidity

I had already tried recreating the symlink. No luck.

Update: I have fingers crossed that I have resolved the problem. It would appear that, when I used superuser privileges to check the integrity of the music store, I looked more carefully at the ownership columns than at the permissions columns (the -rwxrwxrwx columns). I took advantage of having scads of disk space to use superuser again to move everything from /media/stor/ to another large empty ext3 filesystem. There it jumped out at me that the permissions on the music directory were drw------- (0600). That is a no-no. Changed it immediately to 0755 and had full access to the music directory (in its new location in the spare filesystem (i.e. spare physical hard disk)) from the regular unprivileged user account. Am now in the process of copying everything back to /media/stor and will re-create the symlink with my fingers crossed.

A classic case of "haste makes waste". Will report back if the system is fully "stabilized".

Bruce Miller
Ottawa ON, Canada
bruce [ at ] brmiller [ dot ] ca
(613) 745-1151
This message is from a webmail login and not from my regular mail system. It does not have my customary digital signature.

----- Original Message ----
From: Damian Gerow <dgerow [ at ] afflictions [ dot ] org>
To: linux [ at ] lists [ dot ] oclug [ dot ] on [ dot ] ca
Sent: Monday, May 26, 2008 2:29:30 PM
Subject: Re: [OCLUG-Tech] Rescuing user from his own stupidity

Thus spake Bruce Miller (subscribe [ at ] brmiller [ dot ] ca) [26/05/08 14:00]:
: alias permsvfat2linux='find . -perm -0770 -not -type d -exec chmod 0640 \{\} \;cd'


: I am now locked out from both ~/music/ and /media/stor/music. A verbose file listing (ls -l) brings up a list of "Permission denied" errors followed by the file list of /media/stor/music/ preceded by a sea of question marks ("?").

Have you tried removing and re-creating the symlink?  The "-not -type d"
would have applied the permissions changes to all files, be they special
(i.e. FIFOs and symlinks) or normal.

It's possible that a "chmod 0770" would suffice as well.
Linux mailing list
Linux [ at ] lists [ dot ] oclug [ dot ] on [ dot ] ca