home | list info | list archive | date index | thread index

Re: [OCLUG-Tech] Re: Feisty Wireless Problems (Intel 3945ABG)

C.T. Paterson wrote:

Michael's response notwithstanding - the thundering silence suggests
to me that I might have hit across a puzzler...or at least a problem
others on the list have not encountered.  If there are no objections,
I'll continue publishing my results (or lack thereof) to the list for
the sake of the archives...

I downloaded the Ubuntu Gutsy beta CD today, and tried it out.  While
the live CD did load on my laptop (unlike Feisty), it did not remedy
my wireless issues.  Gutsy seems to use version 1.2.2 of the ipw3945
driver (feisty had 1.2.0).  A colleague who is using the same driver
on the same card on another laptop reports having no problems - though
he is on a
WPA authenticated network.  So, I'm left with a few theories - none of
which strike me as compelling:

1. It's a problem the driver has with WEP.  I have received assurances
on various websites that WEP is supposed to work, and I've read many
testimonials that ipw3945 wireless "works for me" from the web
denizens, although I've read no one who thought to specify that it
works with WEP.  I've yet to have the opportunity to try connecting to
a WPA network - however, I'm starting a new job next week, and
visiting someone with a wireless network next weekend; so if I'm
lucky, one of them will have just such a network.

2. It's not a problem with the driver at all, but something else on my
system.  I'm at a loss to know what that might be.  I've installed and
configured other things on my laptop - but I believe trying a wireless
connection was one of the early things I attempted since my
configuration often involved downloading drivers and such, and wiring
my laptop typically involves me disconnecting one of my other machines
from the network.  Further to that, I booted from a live Gutsy CD, and
tried wireless right away - so if it's a system misconfig, then its
happening from the default config.

3. A hardware problem; it's a new card, and works just fine if we
dispense with the authentication.

4. A WAP-end problem; I've had this issue in two separate WEP networks
that I know other wireless clients (non-Linux) have connected to.

So, I'm stumped.  In the mean-time, I'm leaving my wireless
unencrypted, and I've configured the router to only allow my MAC
addresses access to the internet.  I've got SMB shares that are
password protected, and NFS mounts only to authorized IP addresses.  I
use SSH to connect between PCs, no telnet.  I think I'm reasonably
safe from a home network security POV (though if I've missed
something, please let me know), you know, given that I've opened the
network, but I'm still not crazy about this setup.

Still - barring any new ideas on how to deal with the WEP
authentication problem, I'm running out of things to try.


On 28/09/2007, C.T. Paterson <i [ dot ] adore [ dot ] my [ dot ] 64 [ at ] gmail [ dot ] com> wrote:
Some progress - but not yet a win...

The problem seems to be with the authentication.  I'm on my wireless
network now, but could only achieve this by turning my encryption off
(a situation I'm not eager to keep up).  Both my network, and the
wireless network at work use WEP for encryption. I've had someone
suggest to me that I'd have more success on a WPA network.

If that's true, then it would go a ways to explaining why some people
seem to have no trouble with this driver, and some have a world of
problems.  Until I have a WPA test case, though, it'll have to remain
a theory.

I've tried both entering my encryption key and essid in the
NetworkManager, on the command line using iwconfig, and in the
/etc/network/interfaces.  Nothing seems to work -- although if anyone
has time to kill and feels like explaining the difference between an
open and shared key, I'm interested.  There's nothing of the kind
presented when I'm configuring my router.

When you are entering the WEP key, make sure you choose ASCII or HEX to match your settings in the router. I've seen this type of problem with clients entering WEP keys at workstations not checking if the key is preset to be one type or the other. Most client configuration will happily accept whatever you enter without type-checking the data to see if it matches the setting.