home | list info | list archive | date index | thread index

[OCLUG-Tech] trying to install centos 6.5 on USB drive on UEFI-enabled laptop

While not specific to CentOS.  Can the below process be done similar
in CentOS/Fedora, using equivalent guidance
to what other distributions do?

I have successfully dual boot a brand-name laptop from the DVD install
media from SuSE Linux 11 SP3 Install Media
with UEFI.  What I did first was to enter Advanced Disk Partitioning,
carve down the Win8 install, and create a new
Separate-EFI volume (FAT) for Linux, and an ext3 boot partition.  Then
I allowed YaST to partition the free-space
for the default install with GNOME desktop and dev tools in the
remaining space.  (Worked fine.)

When the install finished in the EFI menu on the cheap-new-laptop I could see:
  1. Windows 8
  2. SuSe Linux 11 SP3
  3. SuSe Linux EFI partition

Then I boot between them both checking for good function.  Yup it worked,
both OS were fully graphical desktop and no error in boot messages.
It just ran.

UEFI was happy, even though it listed Linux twice for some reason.
This works because
Newer YaST is smart enough to copy the kernel/initrd to the EFI part
and update grub.
When it does this the SuSE team handles signing of the kernel, so that
EFI will boot from
It with-out forcing the user to first do this step in EFI shell.
Vanilla kernels also install from
repo and sign up fine to boot from EFI.  Just remember to run: efibootmgr

Yay, I was happy - I didn't want to touch the UEFI glop with a long
pole.  Except, now I
had all these M$ partitions kicking around taking up GB and GB of
space - Did not
particularly want Win8 installed on the laptop to begin with, but it
came standard at store.
I needed a large Filesystem for virtual machine images.  I decided, I
would dd-out Windows
C-drive and recovery/driver partitions, but not the Windows UEFI
partition to see if it would still boot.

I ran multiple passes to cleanse my hard disk of Win8 (default at
store).   This worked, it
still boot, but for some reason the BIOS did a weird complaining
routine on boot-up for
the first while and said that the Operating System was not installed
or damaged and trying to
get to online/live restore of Windows from BIOS tools.   I just said
ok pressing enter a bunch of
times where it hung unable to find Windows, then restarted and it boot
straight into Liunx.
I then had a large BTRFS file system, which I mounted in fstab where
windows used to be.
It was fine.  But I re-installed grub/efi signing again.  Then
rebooting, no complaints.

>From this day the install is functional and no issues booting.   I
guess you don't need the Windows UEFI
from vendor if it came with Win8, but I kept mine just in case.  As
long as you have a valid EFI boot disk as
DOS file system with certificate-signed kernel.  Many Linux vendors
have caved in and got their
certificates for Secure boot, I think Stallman was worried about those
who cannot obtain such in their
distro, then the UEFI boot stuff likely encumbers the install.

Why not just delete Win8, then run Win7 in the VM if you must have
Windows?  Native Touch support might be
best in Debian/Ubuntu or Desktop release of Linux, I didn't need all
that on my laptop, because it's not a
convertible with the touch screen, but I did spend some time updating
X input class for trackpad mouse device,
with the two finger scrolling, etc.

Arch Linux had a great tutorial that helped alot for trackpad usability.

Something to note, the SuSe kernel handled PM/ACPI events such as
suspend and hibernate correctly right from the
install, but I had to move up to a newer kernel for wlan support or
build in the broadcom drivers as kmod.  When I wanted
a newer 3.x kernel from an opensuse repo due to compiling some file
system modules, suspend is not working
anymore, haven't figured-out why.  But I'd rather have it that way,
then to be stuck to older SuSE kernel all the time
- despite the support level, until I get the Correct config lines to
re-enable suspend, then it will all work with kernels
build from the SRPM.

BTW, suse has the page for UEFI at:  http://en.opensuse.org/openSUSE:UEFI

(Apparently, you can remove the MS Win8 secure boot keys and install
opensuse certificates, if one reads up on it
and they actually *want to* dive into EFI, then this is a good
exercise; but might void the warranty on the
Laptop/computer. It would still need a boot efi part with fat fs.)

Allan Fields
Ottawa, Canada

Date: Tue, 31 Dec 2013 04:29:15 +0000
From: Mike Rosberg
To: "Robert P. J. Day"
Cc: Ottawa Linux Users Group
Subject: Re: [OCLUG-Tech] trying to install centos 6.5 on USB drive on
	UEFI-enabled laptop

Hi Robert,

I have no experience booting Linux under UEFI but am interested in your
experience as I await the arrival of a new Zenbook which I plan to
dual-boot Win8 and likely Fedora 20.

One thought that occurs to me after reading through your install process is
that the installed USB drive will be unbootable following the OS install as
it will be lacking a EFI System Partition. I suspect you could continue to
use the UEFI-compatible bootable USB drive for that purpose, but would
require the use of two USB drives for every boot. I expect it should be
possible to add an EFI System Partition to the installed USB drive to avoid
the requirement for the UEFI-compatible, bootable USB drive.




On Mon, Dec 30, 2013 at 4:22 PM, Robert P. J. Day wrote:

>   looking for advice on how i can make the following easier. i have a
> class coming up in late january that involves me teaching RHEL 6.5
> (actually, centos 6.5) admin stuff, and i have in front of me a sample
> laptop that each student will have on which to install and mess with
> centos 6.5 for the week, and herein lies the problem.
>   it's an asus ultrabook, UEFI-enabled, running windows 8, and i've
> first been told to try very very hard to not install centos over top
> of the windows installation. no problem ... what i was thinking of
> doing was installing centos onto 16G USB drives so that students can
> mess with their install as much as they want, and take the drive with
> them after the course is over to keep playing. so that part seems
> easy.
>   oh, and the ultrabook has no DVD drive, so i'm limited to 3 USB
> ports (and the SD slot which i have no intention of using. onward.)
>   first issue is that centos 6.5 is not UEFI-compatible, as explained
> here:
> http://linux.web.cern.ch/linux/scientific6/docs/rhel/Installation_Guide/#Making_Minimal_Boot_Media-UEFI
> so i started with following that recipe, and creating a minimal,
> UEFI-compatible, bootable USB drive. boot from that, drop into the
> BIOS, select that USB drive as the boot device and ... yup, it boots,
> so far, so good.
>   however, that's a minimal USB drive, so it would be nice to install
> full centos over the network, and early in the install process, i'm
> given a choice of where the install image is, so i select "NFS
> directory", at which point i see simply "Waiting for NetworkManager to
> configure wlan0" ... and ... "There was an error configuring your
> network interface."
>   ok, fine, i'll fight with the network later. for now, i'll create a
> *second* (8G) USB drive with the full centos 6.5 DVD ISO image "dd"ed
> onto it, pop them *both* in the ultrabook, and reboot. oh, and i'll
> put the final 16G USB drive in the superspeed USB port -- that will be
> the installation target.
>   reboot with all three USB drives. in the BIOS, i've disabled Secure
> Boot Control (was that necessary?), and in the last BIOS menu, i can
> see two USB devices, one of which i recognize as the minimal UEFI
> drive so pick that as my boot device, linux starts to book, i get to
> the point where i select where the installation image, and i select
> "/dev/sde1" which corresponds to the USB drive with the full DVD ISO,
> get to partitioning menu and select *only* the 16G USB drive as the
> target install device and let it go, and it's installing as we speak.
> *sigh*.
>   how difficult have i made this for myself? the obstacles are:
> * ultrabook has no DVD drive
> * ultrabook is UEFI boot so i can't boot a regular ISO image off of
> USB drive
> * if i make the required minimal UEFI boot USB device, i need to get
> the full install image from elsewhere and, for now, the network
> doesn't seem to activate (but i'll fight with that later)
>   finally, once the install is finished (just starting right now),
> will i even be able to boot that USB drive? or will UEFI once again
> get in the way?
>   thoughts?
> rday
> --
> ========================================================================
> Robert P. J. Day                                 Ottawa, Ontario, CANADA
>                         http://crashcourse.ca
> Twitter:                                       http://twitter.com/rpjday
> LinkedIn:                               http://ca.linkedin.com/in/rpjday
> ========================================================================

message navigation