home | list info | list archive | date index | thread index

[OCLUG-Tech] TV tuner sound and channel changing problems


I have posted this problem as a bug but am not getting any real


NOTE BELOW: "card 'Hauppauge WinTV-HVR1800'"
NOTE: I am using the latest Fedora 10 released kernel: Linux 

Below is a summary of the exchanges:

Description of problem:
I can get analogue cable tv picture (rogers.com) but no sound.  

~/.tvtime/stationlist seems ok.  Network, channel and title bar tags are as
they should be.  They change as I change channels but the actual picture
doesn't change with the channel but remains showing the video for CNN channel

Additional info:

]$ tvtime -v
Running tvtime 1.0.2.
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /home/bill/.tvtime/tvtime.xml
cpuinfo: CPU Intel(R) Core(TM)2 Duo CPU     E7400  @ 2.80GHz, family 6, model
7, stepping 10.
cpuinfo: CPU measured at 2800.093MHz.
tvtime: Cannot set priority to -10: Permission denied.
xcommon: Display :0.0, vendor The X.Org Foundation, vendor release 10503000
xvoutput: Using XVIDEO adaptor 280: NV17 Video Texture.
speedycode: Using MMXEXT optimized functions.
station: Reading stationlist from /home/bill/.tvtime/stationlist.xml
videoinput: Using video4linux2 driver 'cx23885', card 'Hauppauge WinTV-HVR1800'
(bus PCIe:0000:02:00.0).
...   .

If it is any help, I dual boot into WindowsXP.  The WinTV-HVR-1800 works fine
in Windows.

Also -- I've found this page:
http://www.linuxtv.org/wiki/index.php/Hauppauge_WinTV-HVR-1800.  You can follow
the instructions there but they mention also firmware update which I would skip
for now...  You may try to just install mplayer and try to test with the one
station you can tune: start mplayer to tune the channel, quit it, and then run
mplayer (full commandline at the bottom of the referenced page) -- your card
should provide device with MPEG2 encoded signal including sound (/dev/video1). 

I got the following return when I tried mplayer as suggested on the linuxtv.org site.

]$ mplayer /dev/video1 -vo x11 -nobps -autosync 30 -forceidx -hardframedrop -vc
ffmpeg12 -idle -menu -cache 16384 -cache-seek-min 50 -mc 0 -ni

MPlayer SVN-r28461-4.3.2 (C) 2000-2009 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU     E7400  @ 2.80GHz (Family: 6, Model: 23,
Stepping: 10)
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
[MENU] Can't open menu config file: /home/bill/.mplayer/menu.conf
Struct fs_cfg doesn't have any auto-close field
[MENU] bad attribute auto-close=yes in menu 'open_list' at line 57
Menu initialized: /etc/mplayer/menu.conf

Playing /dev/video1.
Cache fill:  0.00% (0 bytes) 
I was just wondering. I have not set up my remote control for this card
--> "Failed to open LIRC support. You will not be able to use your
remote control."

Since channel changing and volume can be controlled by the remote
perhaps this is the problem?  I ask before experimenting because I don't
want to throw in an unnecessary variable if I can help it.  Or, perhaps
you know how to turn the remote off.  The remote control isn't necessary
or used with the TV Tuner program I downloaded from Hauppauge for use in

I have tried to get instructions from the Hauppauge site, the
Linuxtv.org site and the tvtime site.  Nothing seemed useful, yet all
claim that the Hauppauge WinTV-HVR-1800 PCe should work in Linux.

Regards Bill
Fedora 10, Gnome 2.24.3
Evo.2.24.5, Emacs 22.3.1